PDA

View Full Version : 2004 Doo 800 SDI Grand Touring



famousguy
10-16-2009, 05:51 PM
I have a chance to by a 2004 Grand Touring 800 SDI. 1800 miles on it.

Never owned an SDI or an 800.

Good luck with 600's and 700's, but don't know what to expect out of an 800.

Any known problems the 800 SDI in 04?

Anything I should look for?

mikes99ss
10-16-2009, 05:56 PM
It was the only year they made an sdi800. They had problems with blowing the crank bearings out of them. I would stay away if it were me. just my $0.02

whitedust
10-16-2009, 05:57 PM
Early 800Sdi had overheating problems & they went back to carbs. Doo knew the reason & stopped making them but I don't remember the exact cause. Team Kessler would know maybe they will jump in with all the details.

tman
10-17-2009, 10:15 AM
I have a 2004 800sdi Legend. Going into the 4th season with it and no problems. If you like the ZX chassis they are fine. Pulls the 3 digit fidgits all day long. Haven't changed a plug or Hyfax since new. If it blows fix it or get rid of it, they're just sleds and they break.
http://www.johndee.com/discuss/messages/6/117004.jpg

famousguy
10-17-2009, 10:52 AM
tman-- How many miles do you have on it?

I love the ZX Chassis, and have owned several 600 and 700 that I put over 10,000 miles on with no trouble.

I am just nervous when it comes to that 800 SDI, because I hate to have a trip ruined with a broken sled.

I am just not sure about it when I here of other peoples troubles with them.

mike99ss & whitedust-- Thanks for the advice. Not sure what I am going to do, but I am leaning towards staying away from it.

Anyone else have any input?

whitedust
10-17-2009, 12:53 PM
Contact team Kessler they would know exactly why 800 sdi was overheating. I had this confirmed by doo dealer years ago when doo dropped 800 sdi as I wanted 1 & he told me gone no more & this was the problem & back to 800 carbs. I just don't remember exact details. I think if you like ZX you will really like XP seating ...much better sled. Doo 800s blowing crank bearings was due to bad factory seals & I had 1 in 2003 800 & had to replace entire engine due to rings flaking as well. Fixed 800 doo @ $2,400 rode it & then went to Yam 4s & don't worry about engine blow ups anymore.

tman
10-17-2009, 11:32 PM
Famousguy--I have over 4,000 miles on my 800. Still in storage so don't know exact miles. I had an 03 ADR, great sled but she seized up on me around 4,000 miles. Changed the rings at 1,200 miles. This 04 has been good so far. I think after this one I'm done..........nah!

ezra
10-17-2009, 11:39 PM
sealed crank bearings.I know I had a doo 800 the crank went out at around 2k.my buds around 1900mi.some guys had luck but more had bad.

gigakessler
10-20-2009, 12:28 AM
The 800SDI was not a HO motor so it had around 130HP. I've never seen one so I dont know much their reliability.

http://www.johndee.com/discuss/messages/6/117259.jpg