View Full Version : 08 M8 throttle sticking

12-21-2008, 07:42 PM
I have a 08 M8 and everynow and then the throttle will stick WFO!! kill sled with kill swicth and snap throttle a couple time and works fine. snowmobile only has 100 miles on it. any help would be appreciated also had a problem with key switch feezing up. -4 today with windchills in the -20 to -30 range. kinda sucks messin with it. thanks k smith

10-14-2009, 12:27 PM
Did you ever find out what was causing this. My 2008 600 CFI(EFI) Polaris Dragaon has done this to me a couple of times. Only when I'm WFO in powder too.

10-14-2009, 02:38 PM
Follow this instruction to the "t"....

Remove thumb!!!

10-14-2009, 02:42 PM
more than likely you throttle cable is sticking!!

start with a new cable probley have a kink in it some were

10-14-2009, 04:14 PM
http://www.johndee.com/discuss/clipart/happy.gif I will try the thumb thing, also will look into the cable. Thanks!

10-14-2009, 04:55 PM
cut the tape off the lever, Just kidding Probably cable

10-14-2009, 05:04 PM
This issue sounds like it could be due to a cut in the sheathing on the cable somewhere. I had a similar issue with full return of the throttle on my X-fire on occasion, it did not stick WO though. I thought maybe I was not letting off of the trigger enough. I figured different sled, different handle bar positioning, it must be me. Late this past season I had the telescopic post put in, a cut was discovered in the cable sheath. Possibly something in the factory assembly process? I did replace the cable & no issues since.-Mezz

10-14-2009, 09:15 PM
Hmmm, I thought if the carbs iced or cable stuck and there was no pressure on the throttle, the TPS would cut the engine. At least mine did. Did you bypass the TPS or what ever it's called.

10-14-2009, 10:06 PM
hay mezz did you run your new cable in conduit like on the sp with adj bars.I did that tonight cable was kinda catching on the clip buy clutch I saw a bad buzz senario so I broke out the trailer wiring box and had the flex conduit so I did it.if it would olny snow things like this would not bother me but with no snow all I can do is play with my toys and dream of actualy using it

10-15-2009, 10:06 AM
lvr1000 - No carbs it's an EFI, but you're right about the engine cut off. Didn't bypass anything. When the throttle sticks it does kill the engine. Pain in the a@! to get it restarted when it happens. Thanks mezz for the cable advise. I will look at it. Thanks again all. It's already snowed once in Iowa ! Got the blood pumping.

10-15-2009, 11:00 AM
hey rdladue where do you live in Iowa?

10-15-2009, 11:14 AM
Cedar Rapids area

10-15-2009, 03:12 PM
I knew that rdladue, hence the "or cable stuck"
Do you have an unusual tight bend in the cable?

10-15-2009, 05:19 PM
ezra, no I didn't put the trottle cable in one, but I did do the brake line as it gets a little narrow between steering post and the opening in the dash. It still clears ok, just a precautionary measure.-Mezz